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Introduction to The Geometer’s Sketchpad® Dynamic Geometry Software 
© 2010-02-04 R. Meisel 

 

This tutorial is intended to provide a general overview of some of the capabilities of The Geometer’s 

Sketchpad® dynamic geometry software. Examples of the wide range of sketches available on this 

powerful tool are included in the following pages. 

 

P 2: Use The Geometer’s Sketchpad® to Construct a Working Model of the Pythagorean Theorem 

● What is The Geometer’s Sketchpad®? 

● The Workspace 

● Draw a Right Triangle 

● Measure Lengths 

● Save the Sketch 

● Calculate Squares 

● Draw Squares on the Sides 

● Add a Page 

● Another Way to Draw a Right Triangle 

 

P 7:Use The Geometer’s Sketchpad® to Create and Save Custom Tools 

● What is a Custom Tool? 

● Standard Custom Tools 

● Creating a Custom Tool 

● Create a Parallelogram Tool 

● Create a Rhombus Tool 

● Save Your Tools for Other Sketches 

 

P 11: Use The Geometer’s Sketchpad® to Illustrate a Geometrical Proposition 

 

Use The Geometer’s Sketchpad® to Dynamically Display Derivatives 

● Graph a Function and Draw a Secant 

● Calculate the Derivative 

● Construct Hide/Show Buttons 

 

P 15: Use The Geometer’s Sketchpad® to Create a Sierpinski Triangle: Iteration 

● What is a Sierpinski Triangle? 

● Set Up the Triangle 

● Iterate the Pattern 

● Change the Iterations 

● Sierpinski Tile 

 

P 17: Use The Geometer’s Sketchpad® for Computer Graphics Imagery (CGI) 

● Morph one shape into another. 

● Make an Object Fly and Turn 

● Show Actions in Sequence 
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Use The Geometer’s Sketchpad® to Construct a Working Model of the 

Pythagorean Theorem 
 

(c) 2010-01-30 R. Meisel 

 

In this activity, you will learn how to use the basic tools and menus of The Geometer’s Sketchpad® to 

construct a dynamic working model the Pythagorean Theorem. 

 

What is The Geometer’s Sketchpad®? 

 

  The Geometer’s Sketchpad® (GSP) is dynamic geometry software useful for exploring plane geometry, 

algebra, calculus, statistics, and other branches of mathematics. It is possible to simulate three-

dimensional geometry as well. Thousands of sketches are available on the Internet, most of them free. 

Version 4 is most commonly found in schools, although Version 5 was released late in 2009. Sketches are 

upwardly compatible. Version 5 also includes a provision for saving files in a format that will work on 

Version 4. 

 

The Workspace 

When you run GSP, the workspace looks like this: 
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The tools buttons are at the side, and dropdown menus are along the top. 

 

Draw a Right Triangle: 

    ● Select the Straightedge Tool. 

    ● Click and drag to draw a line segment bounded by two points. 

 

Tip: You can draw a horizontal, vertical, or diagonal segment by holding down the Shift key. 

 

Next, fix an angle at 90°. 

    ● Select the right endpoint of the segment. 

    ● Select the segment. 

    ● From the Construct menu, select Perpendicular Line. 

 

A line perpendicular to the segment is drawn through the point. 

 

    ● Select the Point Tool. 

    ● Draw a point on the perpendicular line. 

    ● Select the perpendicular line. 

    ● From the Display menu, select Hide Perpendicular Line.  

 

Tip: Alternatively, hold down the CTRL key, and press h. 

 

    ● Use the Straightedge Tool to draw segments that complete 

the triangle. 

 

Click and drag each of the vertices in turn. Notice that the triangle 

remains a right triangle at all times. 

 

Measure Lengths 

 

    ● Select the three sides of the triangle. 

    ● From the Measure menu, select Length. 

 

Labels will appear for each of the vertices. Three length 

measurements will be displayed. 

 

Save the Sketch 

 

    ● From the File menu, select Save As... . 

 

Navigate to a suitable directory, and select a descriptive name 

for your sketch. 

 

    ● Select Save. 
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Calculate Squares 

 

    ● From the Measure menu, select Calculate... . 

 

The calculator box will appear. 

 

    ● Click on the measure of the length of the hypotenuse. 

    ● Click on ^, then 2 to complete the square. 

    ● Click on OK. 

 

The square of the hypotenuse will appear.  

 

    ● From the Measure menu, select Calculate... . 

    ● Click on the measure of one of the sides. 

    ● Click on ^, then 2 to complete the square. 

    ● Click on +. 

    ● Click on the measure of the other side. 

    ● Click on ^, then 2 to complete the square. 

    ● Click on OK. 

 

The sum of the squares of the other two sides will appear. 

 

Tip: You can use the Selection Arrow Tool to move a measurement to a convenient location in the 

workspace. 

 

Click and drag each of the vertices in turn. Note 

that the Pythagorean relationship holds at all 

times. 

 

Draw Squares on the Sides 

 

To complete the model, you will draw squares on 

the sides of the triangle. These will change 

dynamically as you drag the vertices. 

 

    ● Double-click on the vertex containing the 

right angle. This marks the point as the centre of 

rotation. 

    ● Select one of the sides, and the vertex at the 

end of the side. 

    ● From the Transform menu, select Rotate... . 

 

A faint point will be plotted to show you the 

location of the rotated point and side. Note that 
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rotations are counter-clockwise.  

 

    ● Change the angle to 270°. 

    ● Click on Rotate. 

 

The rotated segment and point will appear. 

 

    ● Double-click on point C to mark it as the centre of rotation. 

    ● Rotate B and the segment BC about C. 

    ● Use the Straightedge Tool to complete the square. 

    ● Select the four vertices of the square. 

    ● From the Construct menu, select Quadrilateral Interior. 

 

The square will be filled in with colour. You 

can select the interior, and change the colour by 

selecting Color from the Display menu. 

 

Tip: Alternatively, you can right-click on the 

interior, and select Color. 

 

Use this procedure to draw squares on the other 

sides of the triangle. Select colours of your choice. 

 

Finally, construct a triangle interior for the right triangle, 

and colour it. 

 

Save your sketch. 

 

Add a Page 

 

You can add pages to your sketch. 

 

    ● From the File menu, select Document Options... . 

    ● Press Add Page. 

    ● Select Blank Page. 

    ● Press OK. 

 

Your new page will appear. You could also have chosen 

to duplicate the first page. 

 

You can toggle among the pages using the buttons at the lower left of the workspace. You can also use 

Document Options to change the names of the pages. 
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Another Way to Draw a Right Triangle 

 

    ● Select the Compass Tool. 

    ● Draw a circle in the workspace. 

 

Note that the circle is defined by a centre, and a point on the circle. 

 

    ● Use the Transform menu to rotate the point on the circle 180° about the centre. 

    ● Use the Straightedge Tool to draw a diameter. 

    ● Use the Point Tool to draw another point on the circle. 

    ● Use the Straightedge Tool to complete a triangle in the semicircle. 

    ● Select the vertices of the triangle such that the point in the semicircle is the second one selected. 

    ● From the Measure menu, select Angle. 

 

The measure of the angle in the semicircle will appear. Drag each of the 

vertices of the triangle in turn, and observe what happens.  

 

    ● Hide the circle and its centre. 

 

You can now complete a model of the Pythagorean Theorem using this 

triangle, if desired. 
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Use The Geometer’s Sketchpad® to Create and Save Custom Tools 
 

(c) 2010-01-30 R. Meisel 

 

In this activity, you will learn how to use The Geometer’s Sketchpad® to create custom tools, and save 

them such that they are available for all documents. 

 

What is a Custom Tool? 

 

  The Geometer’s Sketchpad® (GSP) comes with some basic tools, such as the Straightedge Tool for 

drawing lines, rays, and line segments, and the Compass Tool for drawing circles based on a centre and a 

point on the circumference. However, you can create tools to automate the drawing of virtually anything 

that can be drawn with GSP. 

 

Standard Custom Tools 

 

GSP comes with a number of standard custom tools. However, before you 

can use them, you must copy them into your Tool Folder. The standard 

custom tools are placed in the Sketchpad/Samples/Custom Tools directory 

when you install GSP on your computer. You must copy the files in this 

folder to the Sketchpad/Tool Folder folder.  

 

 

 

Close GSP, and restart. Press and hold the Custom Tool button. A list of 

custom tools appears. 

 

You can experiment with the many different and useful tools available. 

 

Creating a Custom Tool 

 

You can create your own custom tool by making a sketch, selecting the 

elements that you want to be part of the tool, and then, selecting Create 

New Tool... from the Custom Tool menu.  

 

If you save the sketch in your Tool Folder, it will appear the next time to 

start GSP. 
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Draw a Parallelogram 

    ● Draw two line segments from the same starting point. 

    ● Select one segment, and the endpoint of the other.  

    ● From the Construct menu, select Parallel Line. 

    ● Repeat to draw another line to complete the figure 

    ● Select the two lines. 

    ● From the Construct menu, select Intersection. 

    ● Hide the two lines. 

    ● Draw line segments to complete the parallelogram. 

 

Create a Parallelogram Tool 

    ● Click and drag to form a selection box. 

 

This will select all objects within the box. 

 

    ● Press the Custom Tool button. 

    ● Select Create New Tool... . 

 

The New Tool box will appear. 

 

    ● Name the tool Parallelogram. 

    ● Press OK. 

 

Press the Custom Tool button. Notice that the Parallelogram tool 

appears in the list under This Document. If you save this document, and 

give it to someone else, the tool will go with it. However, as soon as you 

close the document, the tool will disappear from the list. 

 

To save the tool permanently on your computer, you must save the document in the Tool Folder. It will 

then appear the next time you start GSP. Before doing this, we’ll create another tool. You can create 

many tools in one sketch, and then, save them all at once. 

 

Let’s draw a few parallelograms before we proceed.  

 

    ● Press the Custom Tool button. 

    ● Select Parallelogram. 

    ● Move the pointer to the workspace, and click once. 

    ● Move the pointer, and click again. 

    ● Move the pointer, and click a third time. 

 

Notice that you need to define three points in order to draw a parallelogram.  

 

The parts of the sketch that were hidden, i.e., the two intersecting lines, are not drawn when using the 

tool. Even if you select Show All Hidden from the Display menu, you will not see them. 
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    ● Select and delete all of the parallelograms except the first one.  

    ● Select the Text Tool. 

    ● Type some text such as “This tool draws a parallelogram.” 

 

Add a Page 

 

    ● From the File menu, select Document Options... . 

    ● Press Add Page. 

    ● Select Blank Page. 

    ● Press OK. 

 

Your new page will appear. 

 

    ● From the File menu, select Document Options... . 

 

Change the name of the page to Rhombus. 

 

Change the name of the first page to Parallelogram. Then, return to the Rhombus page. 

 

Draw a Rhombus 

    ● Use the Compass Tool to draw a circle. 

    ● Use the Point Tool to place another point point on the circle. 

    ● Use the Straightedge Tool to draw line segments. 

    ● Construct two lines to form the rhombus. 

    ● Construct the intersection of the lines. 

 

Your sketch will appear as shown. 

 

    ● Hide the lines and the circle. 

    ● Draw line segments to complete the rhombus. 

 

Create a Rhombus Tool 

    ● Click and drag to form a selection box. 

    ● Press the Custom Tool button. 

    ● Select Create New Tool... . 

 

The New Tool box will appear. 

 

    ● Name the tool Rhombus. 

    ● Press OK. 

 

Press the Custom Tool button. Notice that both the Parallelogram tool and the Rhombus tool appear in 

the list under This Document. 
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    ● Press the Custom Tool button. 

    ● Select Rhombus. 

    ● Move the pointer to the workspace, and click once. 

    ● Move the pointer, and click again. 

 

Notice that you only need to define two points in order to draw a rhombus.  

 

Save Your Tools for Other Sketches 

 

    ● From the File menu, select Save As... . 

    ● Navigate to the directory Sketchpad/Tool Folder. 

    ● Type a name for the file, such as My Custom Tools. 

    ● Press Save. 

 

If you press the Custom Tool button, 

you’ll notice that the new tools do not 

appear. You must close and restart GSP. 

Then, the new tools will appear. 
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Use The Geometer’s Sketchpad® to Illustrate a Geometrical Proposition 
 

(c) 2010-01-31 R. Meisel 

 

In this activity, you will learn how to use The Geometer’s Sketchpad® to derive and illustrate a 

geometrical conjecture.  

 

Part 1:  Start with any quadrilateral. Find the midpoints of the sides. Join the midpoints with line 

segments. Form a conjecture about the figure made up of the segments, and show evidence that your 

conjecture is correct. 

 

Sketch the Figure 

    ● Use the Straightedge Tool to sketch any quadrilateral. 

    ● Select the sides, and construct midpoints. 

    ● Select the midpoints and construct line segments. 

 

The interior quadrilateral appears to be a parallelogram. 

    ● Select the sides of the interior quadrilateral. 

    ● From the Measure menu, select Slope. 

 

The slopes of opposite sides are equal. The figure is a parallelogram. 

 

Drag the vertices of the original quadrilateral. The interior figure remains a parallelogram. 

 

Drag any vertex until it overlaps the vertex next to it. Try both directions. 

 

Part 2: Start with any quadrilateral. Find the midpoints of the sides. Erect an external perpendicular at the 

midpoint, whose length is half the length of the corresponding side. Join the ends of opposite 

perpendiculars to construct two line segments. Form a conjecture about the two segments, and show 

evidence that your conjecture is correct. 

 

    ● Use the Straightedge Tool to sketch any quadrilateral. 

    ● Select the sides, and construct midpoints. 

    ● Double-click a midpoint to select it as a centre of rotation. 

    ● Click the point at one end of the same side. 

    ● From the Transform menu, select Rotate... . 

    ● If necessary, change the angle to rotate outside the 

quadrilateral. 

    ● Press Rotate. 

    ● Repeat for the other three sides. 

    ● Draw line segments for the four perpendiculars. 

    ● Join the ends of opposite perpendiculars. 

 

The two segments appear to be orthogonal. 
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    ● Construct the intersection of the two segments. 

    ● Measure the angle at the intersection. 

 

The two segments are orthogonal. Drag the vertices of the original quadrilateral. The two segments 

remain orthogonal. 

 

    ● Select the line. 

    ● From the Measure menu, select Slope. 

 

Part 3: 

 

    ● Use the Straightedge Tool to sketch any acute triangle. 

    ● Construct the midpoints of the sides. 

    ● Construct altitudes. 

    ● Construct the orthocentre: where the altitudes meet. 

    ● Construct a point at the foot of each altitude. 

    ● Hide the altitudes. 

    ● Construct a line segment from each vertex to the 

orthocentre. 

    ● Construct the midpoints of the line segments. 

    ● Hide the orthocentre and the line segments. 

 

You should have nine points visible, other than the vertices of 

the triangle. These points appear to lie on a circle. 

 

    ● Make constructions necessary to find the centre of such a circle. 

    ● Hide all constructions except the centre. 

    ● Draw the circle. 

 

Note that it passes through all nine points. This is called the Nine Point Circle. 

 

Drag a vertex of the triangle. Note that the nine points remain on a circle. 

 

Try another sketch, but use an oblique triangle. 
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Use The Geometer’s Sketchpad® to Dynamically Display Derivatives 
 

(c) 2010-01-31 R. Meisel 

 

In this activity, you will learn how to dynamically work with derivatives in The Geometer’s Sketchpad®. 

 

Graph a Function and Draw a Secant 

    ● From the Edit menu, select Preferences... . 

    ● Select the Text tab. 

    ● Check the box For All New Points. 

    ● Press OK. 

    ● From the Graph menu, select Plot New Function... 

. 

    ● Type x ^ 2. 

    ● Press OK. 

 

The function and graph will be displayed. 

 

    ● Use the Point Tool to draw two points on the function. 

    ● Construct a line through the two points. 

    ● Select the line. 

    ● From the Measure menu, select Slope. 

 

Drag each point independently, and observe how the slope of the secant changes. 

 

Calculate the Derivative 

    ● Select the function. 

    ● From the Graph menu, select Derivative. 

 

The derivative of the function will be displayed. 

 

    ● Measure the coordinates of the first point A.  

    ● Calculate the derivate using the x-coordinate of A. 

    ● Drag point B towards point A. 

 

Observe the relation between the slope of the secant and 

the derivative as point B approaches A. 

 

    ● From the Graph menu, select Plot New Function... 

. 

    ● Enter the expression f’(xA)*(x - xA) + yA 

    ● Press OK. 

 

The tangent at point A will be displayed. 
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Drag point B towards point A. Observe the secant in relation to the tangent. 

 

Construct Hide/Show Buttons 

    ● Select point B, the secant, and the slope of the secant. 

    ● From the Edit menu, select Action Buttons. 

    ● Select Hide/Show. 

 

A button will be displayed. 

 

    ● Right-click on the button, and change the label to Hide Secant. 

    ● Use the button to hide or show the secant. 

 

In a similar manner, create another button to hide/show the tangent and its measurements. 

 

Hide the secant. Drag point A along the curve, and observe what happens.  

 

Show the secant. 

 

Try Another Function 

    ● Right-click on the function definition. 

    ● Select Edit Function... . 

    ● Change the function to x
3
. 

 

Observe what changes have occurred. Experiment with 

the secant and the tangent. 

 

Try other functions of interest. 
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Use The Geometer’s Sketchpad® to Create a Sierpinski Triangle: Iteration 
 

(c) 2010-01-31 R. Meisel 

 

In this activity, you will learn how to use iteration in The Geometer’s Sketchpad® to create a Sierpinski 

Triangle. 

 

What is a Sierpinski Triangle? 

 

  The Sierpinski Triangle is a fractal pattern first described in 

1915 by the Polish mathematician Waclaw Sierpinski. The 

pattern continues indefinitely, and looks the same under any level 

of magnification. A Sierpinski Triangle with five levels is shown.  

 

Set Up the Triangle 

    ● From the Edit menu, select Preferences... . 

    ● Select the Text tab. 

    ● Check the box For All New Points. 

    ● Press OK. 

 

This will label all points as you create them. 

 

    ● Use the Straightedge Tool to draw a triangle. 

    ● Select the sides AB, BC, and CA, in order. 

    ● From the Construct menu, select Midpoints. 

    ● Use the Straightedge Tool to join the midpoints. 

    ● Select the three midpoints. 

    ● From the Construct menu, select Triangle Interior. 

    ● If desired, you can right-click on the triangle, and change the 

Color. 

 

Iterate the Pattern 

Map the pattern in the large triangle into each of the three white triangles. 

    ● Select, in order, the points A, B, and C. 

    ● From the Transform menu, select Iterate... . 

    ● Click on F, B, and D, in order. 

    ● Press the Structure button. 

    ● Select Add New Map. 

This maps the vertices of the triangle ABC to the vertices of the triangle FBD. 

 

In a similar manner, map ABC onto EDC, and AFE. 

 

    ● Click on E, D, and C, in order. 

    ● Press the Structure button. 
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    ● Select Add New Map. 

    ● Click on A, F, and E, in order. 

    ● Press Iterate. 

 

The mapping will be iterated 3 times, the default setting. 

 

Clean up the diagram by selecting and hiding all of the points. 

 

Change the Iterations 

    ● Use the Selection Arrow Tool to draw a selection box 

around the entire triangle. 

    ● Press + to increase the number of iterations, or – to 

decrease the number of iterations. 

 

Sierpinski Tile 

Extend the method to form a tile. 

    ● Draw a square ABCD. 

    ● Construct midpoints for the sides.  

    ● Join the midpoints with line segments. 

    ● Construct midpoints for the segments. 

    ● Join the second set of midpoints. 

 

Your diagram should look much like this at this stage. 

 

    ● Construct triangle interiors for the smaller triangles. 

 

 

 

 

Determine a mapping that results in the pattern shown. Then, 

apply and iterate the mapping. 

 

Select the tile, and experiment with the number of iterations. 

 

Note: GSP will differentiate functions much like a Computer 

Algebra System (CAS). 
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Use The Geometer’s Sketchpad® for Computer Graphics Imagery (CGI) 
 

(c) 2010-02-01 R. Meisel 

 

In this activity, you will learn how to use The Geometer’s Sketchpad® as a CGI program, investigating 

how computers are used in the motion picture industry to create special effects needed in modern film-

making.  This kind of software makes heavy use of trigonometry to render three-dimensional objects on a 

two-dimensional computer screen. 

 

Although The Geometer's Sketchpad® is a two-dimensional program, it can be used to represent and 

animate three-dimensional representations in a limited way. 

 

Part 1: Morph one shape into another. 

Create two shapes. 

    ● Use the Straightedge Tool to draw a letter H. 

    ● Select all points and line segments, and copy. 

    ● Paste a copy of H, and move it away from the original. 

    ● Draw points on the copy to form the letter X. 

    ● Select all points and line segments on the X. 

    ● From the Edit menu, select Action Buttons. 

    ● Create a Hide/Show button for the X. 

 

Morph the H into the X. 

    ● Show the X. 

    ● Select the upper left point on the H. 

    ● Select the upper left point on the X. 

    ● Working clockwise, continue selecting points, alternating between H and X. 

    ● From the Edit menu, select Action Buttons. 

    ● Select Movement... . 

    ● Click on the Label tab, and change the name to : H to X. 

    ● Press OK. 

    ● Hide X. 

    ● Press the H to X button. 

 

The H will morph smoothly into the X. To return the H to the starting position, press CTRL Z. 

 

Right-click on the H to X button. Experiment with the movement settings. 

 

Part 2: Make an Object Fly and Turn 

 

Create starting and finishing shapes. 

    ● Use the Straightedge Tool to draw an object cube. 

    ● Create quadrilateral interiors to colour two of the faces as shown. 
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    ● Draw a larger, rotated version of the cube to the right and down. 

    ● Determine how points on the object cube match with the image cube. 

    ● Select pairs of matching points, in order. 

    ● From the Edit menu, select Action Buttons. 

    ● Select Movement... . 

    ● Click on the Label tab, and change the name to : Fly and Turn. 

    ● Press OK. 

    ● Select all elements of the image cube. 

    ● From the Edit menu, select Action Buttons. 

    ● Create a Hide/Show button for the image cube. 

    ● Hide the image cube. 

    ● Press the Fly and Turn button. 

 

The object cube will appear to fly, turn, and move closer.Note that 

the aspect of the cube does not remain quite right as it flies. To fix 

this problem, points are usually constrained to fly along a predetermined path. You can`t have spaceships 

or dinosaurs changing aspect as they move. 

 

Part 3: Show Actions in Sequence 

  You can combine several motions to form a sequence of actions. 

    ● Draw 8 points close together. 

    ● Create a Hide/Show button for the points. 

    ● Map the points on the object cube to the cluster of 8 points. 

    ● Create a movement button. Label it Hyperspace. 

    ● Hide the point cluster. 

    ● Press the Fly and Turn Button, and then the Hyperspace button. 

 

The object cube first flies to the image cube position, and then, off into hyperspace. 

 

Press CTRL Z twice to return the object cube to its initial position. 

 

You can create a button that combines the two motions. 

    ● Select the Fly and Turn button, and the Hyperspace button, in order. 

    ● From the Edit menu, select Action Buttons. 

    ● Select Presentation... . 

    ● Select the Sequentially button. 

    ● Press OK. 

 

A new button called Sequence 2 Actions will be displayed. Press this button. The actions will occur 

sequentially. 

 

Finally, you can made the object disappear after going into Hyperspace. Create a Hide/Show button for 

the object cube. Select the Fly and Turn, Hyperspace, and Hide Object buttons. Create a presentation 

button. When you press this button, the object cube will disappear after going into hyperspace. 


